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Copyright and License Agreement

Disclaimer of Warranty
Synplicity, Inc. makes no representations or warranties, either expressed or 
implied, by or with respect to anything in this material, and shall not be liable 
for any implied warranties of merchantability or fitness for a particular 
purpose of for any indirect, special or consequential damages.

Copyright Notice
Copyright © 1994-2005 Synplicity, Inc. All Rights Reserved.

Synplicity software products contain certain confidential information of 
Synplicity, Inc. Use of this copyright notice is precautionary and does not 
imply publication or disclosure. No part of this material may be reproduced, 
transmitted, transcribed, stored in a retrieval system, or translated into any 
language in any form by any means without the prior written permission of 
Synplicity, Inc. While every precaution has been taken in the preparation of 
this material, Synplicity, Inc. assumes no responsibility for errors or 
omissions. This material and the features described herein are subject to 
change without notice.

Trademarks
Synplicity, the Synplicity “S” logo, Amplify, Certify, Synplify, Synplify Pro, 
Synplify ASIC, Amplify ASIC, RealPower, HDL Analyst, SCOPE, Behavior 
Extracting Synthesis Technology, Embedded Synthesis, Simply Better 
Synthesis, Simply Better Results, and Synthesis Constraint Optimization 
Environment are registered trademarks, and BEST, DST, Direct Synthesis 
Technology, MultiPoint, Partition-Driven Synthesis, PowerPlanner, Physical 
Synthesis, Synplify Lite, and Total Optimization Physical Synthesis are trade-
marks of Synplicity, Inc. Verilog is a registered trademark of Cadence Design 
Systems, Inc. IBM and PC are registered trademarks of International 
Business Machines Corporation. Microsoft is a registered trademark of 
Microsoft Corporation. Sun, SPARC, Solaris, and SunOS are trademarks of 
Sun Microsystems, Inc. UNIX is a registered trademark of X/Open Corpo-
ration.
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All other product names mentioned herein are the trademarks or registered 
trademarks of their respective owners.

Restricted Rights Legend
Government Users: Use, reproduction, release, modification, or disclosure of 
this commercial computer software, or of any related documentation of any 
kind, is restricted in accordance with FAR 12.212 and DFARS 227.7202, and 
further restricted by the Synplicity Software License Agreement. Synplicity, 
Inc., 600 West California Avenue, Sunnyvale, CA 94086, U. S. A.

September 2005
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Synplicity Software License Agreement

Important!  READ CAREFULLY BEFORE PROCEEDING

BY INDICATING YOUR ACCEPTANCE OF THE TERMS OF THIS AGREEMENT, YOU (“LICENSEE”) 
ARE REPRESENTING THAT YOU HAVE THE RIGHT AND AUTHORITY TO LEGALLY BIND YOUR-
SELF OR YOUR COMPANY, AS APPLICABLE, AND CONSENTING TO BE LEGALLY BOUND BY 
ALL OF THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL THESE TERMS DO 
NOT INSTALL OR USE THE SOFTWARE, AND RETURN THE SOFTWARE TO THE LOCATION OF 
PURCHASE FOR A REFUND. This is a legal agreement governing use of the software program provided by 
Synplicity, Inc. (“Synplicity”) to you (the “SOFTWARE”). The term “SOFTWARE” also includes related doc-
umentation (whether in print or electronic form), any authorization keys, authorization codes, and license files, 
and any updates or upgrades of the SOFTWARE provided by Synplicity, but does not include certain “open 
source” software licensed by third party licensors and made available to you by Synplicity under the terms of 
such third party licensor’s license (such as software licensed under the General Public License (GPL)) (“Third 
Party Software”). If Licensee is a participant in the University Program or has been granted an Evaluation 
License or Subscription License, then some of the following terms and conditions may not apply (refer to the 
sections entitled, respectively, Evaluation License and Subscription License, below). 

License. Synplicity grants to Licensee a non-exclusive right to install the SOFTWARE and to use or authorize 
use of the SOFTWARE by up to the number of nodes for which Licensee has a license and for which Licensee 
has the security key(s) or authorization code(s) provided by Synplicity or its agents for the purpose of creating 
and modifying Designs (as defined below). If Licensee has obtained the SOFTWARE under a node-locked 
license, then a “node” refers to a specific machine, and the SOFTWARE may be installed only on the number 
of “nodes” or machines authorized, must be used only on the machine(s) on which it is installed, and may be 
accessed only by users who are physically present at that node or machine. A node-locked license may only be 
used by one user at a time running one instance of the software at a time. If Licensee has obtained the SOFT-
WARE under a “floating” license, then a “node” refers to a concurrent user or session, and the SOFTWARE 
may be used concurrently by up to the number of users or sessions indicated. All SOFTWARE must be used 
within the country for which the systems were licensed and at Licensee's Site (contained within a one kilome-
ter radius); however, if Licensee has a floating license then remote use is permitted by employees who work at 
the site but are temporarily telecommuting to that same site from less than 50 miles away (for example, an 
employee who works at a home office on occasion), but the maximum number of concurrent sessions or nodes 
still applies. In addition, Synplicity grants to Licensee a non-exclusive license to copy and distribute internally 
the documentation portion of the SOFTWARE in support of its license to use the program portion of the 
SOFTWARE. For purposes of this Agreement the “Licensee’s Site” means the location of the server on which 
the SOFTWARE resides, or when a server is not required, the location of the client computer for which the 
license was issued.

Evaluation License. If Licensee has obtained the SOFTWARE pursuant to an evaluation license, then, in 
addition to all other terms and conditions herein, the following restrictions apply: (a) the license to the SOFT-
WARE terminates after 20 days (unless otherwise agreed to in writing by Synplicity); and (b) Licensee may 
use the SOFTWARE only for the sole purpose of internal testing and evaluation to determine whether Lic-
ensee wishes to license the SOFTWARE on a commercial basis. Licensee shall not use the SOFTWARE to 
design any integrated circuits for production or pre-production purposes or any other commercial use includ-
ing, but not limited to, for the benefit of Licensee’s customers. If Licensee breaches any of the foregoing 
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restrictions, then Licensee shall pay to Synplicity a license fee equal to Synplicity’s perpetual list price plus 
maintenance for the commercial version of the SOFTWARE.

Subscription (Time-Based) License. If Licensee has obtained a Subscription License to the SOFTWARE, 
the, in addition to all other terms and conditions herein, the following restrictions apply: (a) Licensee is autho-
rized to use the SOFTWARE only for a limited time (which time is indicated on the quotation or in the pur-
chase confirmation documents); (b) Licensee’s right to use the SOFTWARE terminates on the date the 
subscription term expires as set forth in the quotation or the purchase confirmation documents, unless Licensee 
has renewed the license by paying the applicable fees.

Project Based License. If Licensee has obtained a Project-Based License to the SOFTWARE, in addition to 
all other terms and conditions herein, the terms of Exhibit A will apply.

Copy Restrictions. This SOFTWARE is protected by United States copyright laws and international treaty 
provisions and Licensee may copy the SOFTWARE only as follows: (i) to directly support authorized use 
under the license, and (ii) in order to make a copy of the SOFTWARE for backup purposes. Copies must 
include all copyright and trademark notices. 

Use Restrictions. This SOFTWARE is licensed to Licensee for internal use only. Licensee shall not (and shall 
not allow any third party to): (i) decompile, disassemble, reverse engineer or attempt to reconstruct, identify or 
discover any source code, underlying ideas, underlying user interface techniques or algorithms of the SOFT-
WARE by any means whatever, or disclose any of the foregoing; (ii) provide, lease, lend, or use the SOFT-
WARE for timesharing or service bureau purposes, on an application service provider basis, or otherwise 
circumvent the internal use restrictions; (iii) modify, incorporate into or with other software, or create a deriva-
tive work of any part of the SOFTWARE; (iv) disclose the results of any benchmarking of the SOFTWARE, or 
use such results for its own competing software development activities, without the prior written permission of 
Synplicity; or (v) attempt to circumvent any user limits, maximum gate count limits or other license, timing or 
use restrictions that are built into the SOFTWARE. 

Transfer Restrictions/No Assignment. The SOFTWARE may only be used under this license at the desig-
nated locations and designated equipment as set forth in the license grant above, and may not be moved to 
other locations or equipment or otherwise transferred without the prior written consent of Synplicity. Any per-
mitted transfer of the SOFTWARE will require that Licensee executes a “Software Authorization Transfer 
Agreement” provided by Synplicity.   Further, Licensee shall not sublicense, or assign this Agreement or any 
of the rights or licenses granted under this Agreement, without the prior written consent of Synplicity.

Security. Licensee agrees to take all appropriate measures to safeguard the SOFTWARE and prevent unautho-
rized access or use thereof. Suggested ways to accomplish this include: (i) implementation of firewalls and 
other security applications, (ii) use of FLEXlm options file that restricts access to the SOFTWARE to identi-
fied users; (iii) maintaining and storing license information in paper format only; (iv) changing TCP port num-
bers every three (3) months; and (v) communicating to all authorized users that use of the SOFTWARE is 
subject to the restrictions set forth in this Agreement. 

Ownership of the SOFTWARE. Synplicity retains all right, title, and interest in the SOFTWARE (including 
all copies), and all worldwide intellectual property rights therein.   Synplicity reserves all rights not expressly 
granted to Licensee. This license is not a sale of the original SOFTWARE or of any copy. 

Ownership of Design Techniques. “Design” means the representation of an electronic circuit or device(s), 
derived or created by Licensee through the use of the SOFTWARE in its various formats, including, but not 
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limited to, equations, truth tables, schematic diagrams, textual descriptions, hardware description languages, 
and netlists. “Design Techniques” means the data, circuit and logic elements, libraries, algorithms, search 
strategies, rule bases, techniques and technical information incorporated in the SOFTWARE and employed in 
the process of creating Designs. Synplicity retains all right, title and interest in and to Design Techniques 
incorporated in the SOFTWARE, including all intellectual property rights embodied therein, provided that to 
the extent any Design Techniques are included as part of or embedded within Licensee’s Designs, Synplicity 
grants Licensee a personal, nonexclusive, nontransferable license to reproduce the Design Techniques and dis-
tribute such Design Techniques solely as incorporated into Licensee’s Designs and not on a standalone basis.   
Additionally, Licensee acknowledges that Synplicity has an unrestricted, royalty-free right to incorporate any 
Design Techniques disclosed by Licensee into its software, documentation and other products, and to subli-
cense third parties to use those incorporated design techniques.

Protection of Confidential Information. “Confidential Information” means (i) the SOFTWARE, in object 
and source code form, and any related technology, idea, algorithm or information contained therein, including 
without limitation Design Techniques, and any trade secrets related to any of the foregoing; (ii) either party's 
product plans, Designs, costs, prices and names; non-published financial information; marketing plans; busi-
ness opportunities; personnel; research; development or know-how; (iii) any information designated by the 
disclosing party as confidential in writing or, if disclosed orally, designated as confidential at the time of dis-
closure and reduced to writing and designated as confidential in writing within thirty (30) days; and (iv) the 
terms and conditions of this Agreement; provided, however that “Confidential Information” will not include 
information that: (a) is or becomes generally known or available by publication, commercial use or otherwise 
through no fault of the receiving party; (b) is known and has been reduced to tangible form by the receiving 
party at the time of disclosure and is not subject to restriction; (c) is independently developed by the receiving 
party without use of the disclosing party's Confidential Information; (d) is lawfully obtained from a third party 
who has the right to make such disclosure; and (e) is released for publication by the disclosing party in writing. 

Each party will protect the other's Confidential Information from unauthorized dissemination and use with the 
same degree of care that each such party uses to protect its own like information. Neither party will use the 
other's Confidential Information for purposes other than those necessary to directly further the purposes of this 
Agreement. Neither party will disclose to third parties the other's Confidential Information without the prior 
written consent of the other party.

Third Party Software. Licensee understands and agrees that, although provided to Licensee by Synplicity, 
Licensee’s use of each component library or module comprising the Third Party Software shall be governed by 
the relevant terms and conditions of the third party’s license agreements.

Termination. Synplicity may terminate this Agreement immediately if Licensee breaches any provision, 
including without limitation, failure by Licensee to implement adequate security measures as set forth above. 
Upon notice of termination by Synplicity, all rights granted to Licensee under this Agreement will immedi-
ately terminate, and Licensee shall cease using the SOFTWARE and return or destroy all copies (and partial 
copies) of the SOFTWARE and documentation. 

Limited Warranty and Disclaimer. Synplicity warrants that the program portion of the SOFTWARE will 
perform substantially in accordance with the accompanying documentation for a period of 90 days from the 
date of receipt. Synplicity’s entire liability and Licensee’s exclusive remedy for a breach of the preceding lim-
ited warranty shall be, at Synplicity’s option, either (a) return of the license fee, or (b) providing a fix, patch, 
work-around, or replacement of the SOFTWARE. In either case, Licensee must return the SOFTWARE to 
Synplicity with a copy of the purchase receipt or similar document. Replacements are warranted for the 
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remainder of the original warranty period or 30 days, whichever is longer. Some states/jurisdictions do not 
allow limitations, so the above limitation may not apply. EXCEPT AS EXPRESSLY SET FORTH ABOVE, 
NO OTHER WARRANTIES OR CONDITIONS, EITHER EXPRESS, IMPLIED, STATUTORY OR OTH-
ERWISE, ARE MADE BY SYNPLICITY OR ITS LICENSORS WITH RESPECT TO THE SOFTWARE 
AND THE ACCOMPANYING DOCUMENTATION, AND SYNPLICITY EXPRESSLY DISCLAIMS ALL 
WARRANTIES AND CONDITIONS NOT EXPRESSLY STATED HEREIN, INCLUDING BUT NOT LIM-
ITED TO THE IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, NONINFRINGE-
MENT, AND FITNESS FOR A PARTICULAR PURPOSE. SYNPLICITY AND ITS LICENSORS DO NOT 
WARRANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET LICENSEE’S 
REQUIREMENTS, BE UNINTERRUPTED OR ERROR FREE, OR THAT ALL DEFECTS IN THE PRO-
GRAM WILL BE CORRECTED. Licensee assumes the entire risk as to the results and performance of the 
SOFTWARE. Some states/jurisdictions do not allow the exclusion of implied warranties, so the above exclu-
sion may not apply. 

Limitation of Liability. IN NO EVENT SHALL SYNPLICITY OR ITS LICENSORS OR THEIR AGENTS 
BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROF-
ITS, BUSINESS INTERRUPTIONS, LOSS OF BUSINESS INFORMATION, OR OTHER PECUNIARY 
LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF SYNPLIC-
ITY AND/OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
FURTHER, IN NO EVENT SHALL SYNPLICITY’S LICENSORS BE LIABLE FOR ANY DIRECT DAM-
AGES ARISING OUT OF LICENSEE’S USE OF THE SOFTWARE. IN NO EVENT WILL SYNPLICITY 
OR ITS LICENSORS BE LIABLE TO LICENSEE FOR DAMAGES IN AN AMOUNT GREATER THAN 
THE FEES PAID FOR THE USE OF THE SOFTWARE. Some states/jurisdictions do not allow the limitation 
or exclusion of incidental or consequential damages, so the above limitations or exclusions may not apply. 

Intellectual Property Right Infringement. Synplicity will defend or, at its option, settle any claim or action 
brought against Licensee to the extent it is based on a third party claim that the SOFTWARE as used within the 
scope of this Agreement infringes or violates any US patent, copyright, trade secret or trademark of any third 
party, and Synplicity will indemnify and hold Licensee harmless from and against any damages, costs and fees 
reasonably incurred that are attributable to such claim or action; provided that Licensee provides Synplicity 
with (i) prompt written notification of the claim or action; (ii) sole control and authority over the defense or 
settlement thereof (including all negotiations); and (iii) at Synplicity’s expense, all available information, 
assistance and authority to settle and/or defend any such claim or action. Synplicity’s obligations under this 
subsection do not apply to the extent that (i) such claim or action would have been avoided but for modifica-
tions of the SOFTWARE, or portions thereof, other than modifications made by Synplicity after delivery to 
Licensee; (ii) such claim or action would have been avoided but for the combination or use of the SOFT-
WARE, or portions thereof, with other products, processes or materials not supplied or specified in writing by 
Synplicity; (iii) Licensee continues allegedly infringing activity after being notified thereof or after being 
informed of modifications that would have avoided the alleged infringement; or (iv) Licensee’s use of the 
SOFTWARE is not strictly in accordance with the terms of this Agreement. Licensee will be liable for all dam-
ages, costs, expenses, settlements and attorneys’ fees related to any claim of infringement arising as a result of 
(i)-(iv) above.

If the SOFTWARE becomes or, in the reasonable opinion of Synplicity is likely to become, the subject of an 
infringement claim or action, Synplicity may, at Synplicity’s option and at no charge to Licensee, (a) obtain a 
license so Licensee may continue use of the SOFTWARE; (b) modify the SOFTWARE to avoid the infringe-
ment; (c) replace the SOFTARE with a compatible, functionally equivalent, and non-infringing product, or (d) 
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refund to Licensee the amount paid for the SOFTWARE, as depreciated on a straight-line 5-year basis, or such 
other shorter period applicable to Subscription Licenses.

THE FOREGOIN PROVISIONS OF THIS SECTION STATE THE ENTIRE AND SOLE LIABILITY AND 
OBLIGATIONS OF SYNPLICTY, AND THE EXCLUSIVE REMEDY OF LICENSEE, WITH RESPECT 
TO ANY ACTUAL OR ALLEGED INFRINGEMENT OF ANY INTELLECTUAL PROPERTY RIGHTS 
BY THE SOFTWARE (INCLUDING DESIGN TECHNIQUES) AND DOCUMENTATION.

Export. Licensee warrants that it is not prohibited from receiving the SOFTWARE under U.S. export laws; 
that it is not a national of a country subject to U.S. trade sanctions; that it will not use the SOFTWARE in a 
location that is the subject of U.S. trade sanctions that would cover the SOFTWARE; and that to its knowledge 
it is not on the U.S. Department of Commerce’s table of deny orders or otherwise prohibited from obtaining 
goods of this sort from the United States.

Miscellaneous. This Agreement is the entire agreement between Licensee and Synplicity with respect to the 
license to the SOFTWARE, and supersedes any previous oral or written communications or documents 
(including, if you are obtaining an update, any agreement that may have been included with the initial version 
of the Software). This Agreement is governed by the laws of the State of California, USA excluding its con-
flicts of laws principals. This Agreement will not be governed by the U. N. Convention on Contracts for the 
International Sale of Goods and will not be governed by any statute based on or derived from the Uniform 
Computer Information Transactions Act (UCITA). If any provision, or portion thereof, of this Agreement is 
found to be invalid or unenforceable, it will be enforced to the extent permissible and the remainder of this 
Agreement will remain in full force and effect. Failure to prosecute a party’s rights with respect to a default 
hereunder will not constitute a waiver of the right to enforce rights with respect to the same or any other 
breach. 

Government Users. If the SOFTWARE is licensed to the United States government or any agency thereof, 
then the SOFTWARE and any accompanying documentation will be deemed to be “commercial computer 
software” and “commercial computer software documentation”, respectively, pursuant to DFAR Section 
227.7202 and FAR Section 12.212, as applicable. Any use, reproduction, release, performance, display or dis-
closure of the SOFTWARE and accompanying documentation by the U.S. Government will be governed 
solely by the terms of this Agreement and are prohibited except to the extent expressly permitted by the terms 
of this Agreement.

June 2005
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Amplify ISSP Pro Tutorial Overview
The goal of this tutorial is to familiarize you with the main features of the 
Amplify ISSP Pro physical synthesis tool so that you can use it to achieve 
optimal results for your own designs.

Tutorial Design
This tutorial uses a FIFO design which is configured to support independent 
read and write clock signals. The depth and width of the FIFO are configured 
by setting a parameter in the RTL code. The FIFO used in this tutorial is 
configured and optimized for a 1023 x 32 bit data buffer. FIFO circuits can be 
used in the following types of applications: processors, controllers, and 
various communications circuits. 

See Figure 1 on page -3 for a graphical view of the FIFO architecture. For 
more information about the operation and functionality of the FIFO, see the 
vendor design specification documentation.



Amplify ISSP Pro Tutorial Overview Amplify ISSP Pro Tutorial for ISSP-90

Amplify ISSP Pro Tutorial, September 2005 3

Figure 1:  FIFO Design
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Prerequisites
To complete the tutorial example in the following sections:

• You need a working knowledge of logic design synthesis and basic 
window operations. 

• You should read Chapter 1, Getting Started of the User Guide, which 
presents a brief introduction to the Synplify ASIC and Amplify ASIC 
family of tools. Also, read through Chapter 2, User Interface Overview of 
the Reference Manual, which covers features and views of the Amplify 
ASIC Physical Synthesis UI.

• Create a local copy of the tutorial directory and be sure to delete the 
packet_buffer.prj file so you can create your own. See the Directory 
Structure on page 2-6 for information.

Required Time
The tutorial should take about 2 to 3 hours to complete.

Task Outline
Tasks in this tutorial include the following:

• Bring up the Amplify ISSP Pro GUI

• Open the project

• Check Implementation Options

• Check Timing Constraints

• Run Constraint Check

• View Floorplan

• Synthesize the Design

• Analyze Results
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Download the Tutorial Files
You can download the tutorial design and project files along with the 
tutorial instructions from the Synplicity Technical Resource Center.

1. To access the Synplicity Technical Resource Center:

– Select WEB->Go to Resource Center from the Project menu. Then, go to 
the Tutorial section within the Technical Resource Center.

– Go to http://trc.synplicity.com/tutorials/index.html

2. Find the Amplify ISSP Pro tutorial for the applicable release and 
download these files for the platform you desire.

3. Unzip the tutorial files.

– On a PC, use Winzip to extract the tutorial files.

– On a UNIX platform, type the following at the command line:

gunzip amplify_issp.tar.gz

Then, to extract the tutorial files, type this at the command line:

tar -xvf amplify_issp.tar

4. Copy the amplify_issp/tutorial directory to your working area. Keep the 
directory structure, because the tutorial is based on this structure. 
Refer to Directory Structure on page 2-6. When you work on your own 
designs, you can set up the structure as you want. 

Note: The tutorial instructions are contained in the tutorial.pdf, which 
is also located in this directory. Open this file when you are 
ready to begin the tutorial.

5. Make sure you have read and write privileges for the project files. 



LO

Amplify ISSP Pro Tutorial Overview

6 Amplify ISSP Pro Tutorial, September 2005

Directory Structure
This section contains the directory structure for tutorial, located at:

install_directory/amplify_issp/tutorial

where install_directory is the path to where your Amplify ISSP Pro tutorial 
files and instructions are located. 

Figure 2 shows the tutorial directory in the Project view of the UI that reflects 
the virtual directory structure that is automatically created by the tool as you 
build your design project. 

Figure 2:  Tutorial Directory Structure

However, with your own designs, you can create any directory structure that 
works best. 

Note: You can delete or rename the packet_buffer.prj and the 
fifo.sdc files in this directory so you can create your own as part 
of the tutorial exercises.

packet_buffer.prj

verilog constraint

* This is the top-level module

fifo.sdc

physical librarieslibrary file

ISSP90_STD_NARROW1_1V_MOX_33V.syn

floorplans

black_box.v
async_fifo.v

packet_buffer_with_io_cts_pll.v*

69552.ai.lef

design plans

69552.ai.def fifo.flr
naming_rule_CHIP.nr
naming_rule_MACRO.nr

naming
rules (optional)

core.ai.lef
7L_io40u.ai.lef

m_com.ai.lef
macro.ai.lef
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Input Files
Here is a brief description of the input files:

• .v — contains the HDL source files. packet_buffer_with_io_cts_pll.v 
is the top level module. 

• constraint:fifo.sdc — user-specified constraint file, contains the 
timing constraints. 

• packet_buffer.prj — packet_buffer project file, contains all the infor-
mation required to complete a design. This file contains references to 
source files, and specifications for the target ASIC technology. 

• physical libraries:69552.ai.lef, core.ai.lef, 7L_io40u.ai.lef, 
m_com.ai.lef, macro.ai.lef — physical cell library information that 
includes process layers, design rules associated with interconnect 
layers, via cells and parasitics per layer. The libraries also include size, 
symmetry, and pin characteristics of standard cells and blockages of 
each macro. 

• floorplans:69552.ai.def — device floorplan file which contains infor-
mation such as die size, rows and sites, pin locations, macro locations 
and orientation, or obstructions. 

• design plans:fifo.flr — device floorplan editor file which contains 
floorplan information and allows you to place, move, or change the 
orientation of macros, draw soft and hard placement obstructions, 
define regions constraints for instances of RTL modules, and create 
top-level bounding box constraints.

• library:ISSP90_STD_NARROW1_1V_MOX_33V.syn — ISSP-90 technology 
library in Synplicity internal format. This file contains the merged .sel 
files, which describe the parameters and specifications for the target 
technology. 

• naming rules:naming_rule_CHIP.nr and naming_rule_MACRO.nr — 
includes a naming rules file for the chip and the macros such that the 
rules are defined and applied during synthesis.

Output Files
Figure 3 shows the directory structure for the results files, given the default 
name rev_1. You specify the directory for the results when you define imple-
mentation options for the project. 
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Figure 3:  Results Directory Structure

Here is a brief description of the result files that are written to the implemen-
tation during synthesis:

• .areasrr — a hierarchical report containing area information for each of 
the modules in the design. 

• .def — output floorplan file, contains updated information for any of 
the following: die size, rows and sites, pin locations, macro locations and 
orientation, or obstructions.

• .htm — HTML format of the log file containing the synthesis results. See 
the .srr file for a description of its contents.

• _ilm_lib.v — verilog file containing black box description of all library 
cells.

• .postmap.sdc — timing constraint file that is automatically created for 
in-place optimization. 

rev_1

packet_buffer_with_io_cts_pll.areasrr

amplify_issp/tutorial

* Custom timing report is not 
automatically generated

packet_buffer_with_io_cts_pll.def
packet_buffer_with_io_cts_pll.htm
packet_buffer_with_io_cts_pll.postmap.sdc

 
packet_buffer_with_io_cts_pll.scf
packet_buffer_with_io_cts_pll.sdf
packet_buffer_with_io_cts_pll.srm
packet_buffer_with_io_cts_pll.srr
packet_buffer_with_io_cts_pll.srs
packet_buffer_with_io_cts_pll.ta*
packet_buffer_with_io_cts_pll.vma
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• .scf — Synopsys-style timing constraint file, used for forward annota-
tion in place-and-route tools. See Appendix C, Translating Synopsys 
Constraints of the Reference Manual for information using these 
constraints in the Amplify ISSP Pro environment.

• .sdf — standard delay format file containing pin-to-pin timing delay 
values for nets and instances and timing requirements for sequential 
elements.

• .srm — output by the mapper stage of the process, contains the actual 
technology-specific mapped design. This is the representation displayed 
through the technology view in HDL Analyst and the floorplan view in 
Physical Analyst.

• .srr — log file containing the synthesis results. The project_name.srr 
file contains all warnings and errors encountered during synthesis as 
well as performance information such as clock frequency, critical paths 
and run times. There is also information on area, cell usage and FSM 
extraction. To view this file, click on the View Log button in the Project 
view. 

• .srs — output by the compiler stage of the process, contains the RTL 
level (schematic) view of the design. This is the representation displayed 
through the RTL view in HDL Analyst and the Floorplan Viewer.

• .ta — customized timing report (not generated by default). This file is 
created when you generate a special timing report using the Timing 
Report->Generate command.

• .vma — structural Verilog design netlist for place and route and verifica-
tion.
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Physical Synthesis Design Flow
The typical flow for Amplify ISSP Pro Physical Optimizer is shown in the 
following figure.

Design – Verilog
(.v) or VHDL (.vhd)

Amplify ISSP Pro

 Flow

Timing Constraints
(.sdc)

Tech Library
(.syn*)

Cell Library
(.lef)

Floorplan File
(.def)

Create Project

Set Implementation
Options

Analyze Results

Run Amplify ISSP Pro
(Physical Synthesis mode)

Add Project Files

Structural Verilog 
Netlist (.vma)

Timing Constraints
(.postmap.sdc)

Timing Constraints
(.scf)

Placement 

Load/Resistance

(.def) 

(.setload)

Timing Delay
(.sdf)

Physical Optimizer

Timing Report
 (.ta/.tasrr)

Log File
(.srr/.htm)

Floorplan Editor
(.flr)
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1. Start the Amplify ISSP Pro GUI.

2. Create Project:

– Add source files 

– Specify top-level module/entity

3. Set Implementation Options:

– Choose target technology

– Specify operating conditions and wire load model

– Set optimization switches

– Specify results directory

4. Verify Timing Constraints:

– Compile the design before creating the constraints to initialize SCOPE

– Set timing constraints through SCOPE

– Modify timing constraints as appropriate to improve results

5. Run Constraint Check.

6. View the Floorplan.

7. Synthesize the Design.

– Click Run.

8. Analyze Results:

– Output Files

– Area Report

– Timing Report

– Physical Analyst

– Log File Warnings

9. When design goals are met, go on to place and route and/or verification.
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Start the Amplify ISSP Pro GUI
How you start the tool depends on your environment.

• To start the software from a Windows platform, select 
Programs->Synplicity-> Amplify ISSP Pro from the Start menu. 

• To start the software from a UNIX command line, type:

install_directory/bin/amplify_issp_pro

where: install_directory is the path to where your Amplify ISSP Pro 
software is installed.

For more details on bringing up the tool, installation and licensing, see:

• Installation and Licensing in Chapter 1, Getting Started of the User Guide

• Getting Help in Chapter 1, Get Started of the Reference Manual

• Starting the ASIC Synthesis Tools in Chapter 1, Get Started of the Refer-
ence Manual

Create Project
Before synthesizing a design, you need to create a project for it. The project 
contains all the elements required to run synthesis on a design such as 
technology library, design files, constraint files, and so on. A project can have 
one or more associated revisions, also called implementations. Each time you 
change options, libraries, constraints, or optimization switches to enhance 
performance, you should create a new implementation for the project. This 
way you can compare the results of each of your implementations to deter-
mine the best combination of files and settings that yield the most optimum 
results for the design.



Create Project Amplify ISSP Pro Tutorial for ISSP-90

Amplify ISSP Pro Tutorial, September 2005 13

To open the project:

1. From the Project view, do one of the following:

– Click on the Open Project button

– Click on the project button in the toolbar ( )

– Select File->Open Project

Figure 4:  Create Project

2. Click on New Project.

This creates a new project with an associated revision in the project 
view; default names are proj and rev_1. 

Figure 5:  Create Project
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Add the design files to the project.

3. Click on the Add File button. 

4. Open the rtl_sims folder. Make sure Files of type field is showing either All 
Files (*) or Verilog Files (*.v). 

5. For this exercise, add all the Verilog files in the folder. Click on the <-Add 
All button, then click OK.
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Figure 6:  Add Verilog Files

A virtual design directory structure is created in the Project view. 
Figure 7 shows the UI after adding the design files. 
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Figure 7:  Add Source Files

6. Specify the top-level module.

Figure 8:  Top-Level Module

When you are using a design with only one HDL, you can do this by 
moving the top-level module to the last position in the list of source files 
in the Project view. (Click and drag on the module to move the position.) 
The top-level module is already in the last position for this example.

top-level
module
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7. Click on the Add File button again and change to the ISSP_DEMO_lib/lef 
directory. Make sure Files of type field is showing Physical Library Files (*.lef). 

For this exercise, add all the physical library files in the folder. Click on 
the <-Add All button, then click OK.

A Physical Libraries directory structure is created in the Project view. The 
following figure shows the UI after adding the physical library files. 
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Figure 9:  Add Physical Library Files

8. Add the technology library files to the project. To do this:

– Open the ISSP_DEMO_lib/syn folder.

– Select the ISSP90_STD_NARROW1_1V_MOX_33V.syn file and add it to the 
project.



Create Project Amplify ISSP Pro Tutorial for ISSP-90

Amplify ISSP Pro Tutorial, September 2005 19

A Library File folder is created in the project view.
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9. Add the floorplan files to the project. To do this:

– Open the def_fplan/def folder.

– Select the 69552.ai.def file and add it to the project.

A Floorplans folder is created in the project view.
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10. Add the design plans floorplan file to the project. To do this:

– Open the def_fplan/floorplan folder.

– Select the fifo.flr file and add it to the project.
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A Design Plans folder is created in the project view.

11. This example provides optional naming rule files applied to the chip and 
macros of the design during synthesis. To add these files to the project, 
do the following:

– Open the ISSP_DEMO_lib/naming_rule folder.

– Select the naming_rule_CHIP.nr and naming_rule_MACRO.nr files.
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A Naming Rules folder is created in the project view.
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12. Save the project file as packet_buffer.prj in the tutorial directory (File-> Save 
As).
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Set Implementation Options
The options you set for a project revision (implementation) determine the 
optimization settings and inputs such as the technology library, constraint 
files, operating conditions, and output directory for the synthesis run.

The exercise in this section presents a summary of the implementation 
options as they relate to the tutorial exercise. For more details on setting 
implementation options, see Set Implementation Options in Chapter 2, Project 
Set-up of the User Guide. 

1. You can bring up the Options for Implementation dialog box in the Project 
view with one of the following:

– Impl Options button

– Select Project->Implementation Options

– New Impl button (for creating a new implementation only)

2. Click on the Device tab. 

Figure 10:  Set Device Options
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In summary, this exercise uses the following Device options:

– technology library files = ISSP90_STD_NARROW1_1V_MOX_33V.syn 

– issp master array = 69552

– wire load selection and mode = Enclosed

– wire load model = (None)

– wire load selection group = (None)

– operating conditions (max) = 
ISSP90_STD_NARROW1_1V_MOX_33V_MAX_ABDLSL333IV10.BEST_TREE 

– operating conditions (min) = (None)

3. Click on the Options tab.

Figure 11:  Set Option Switches

The following switches are enabled for this exercise:

– Resource Sharing

– Disable I/O Insertion

– Prune Unused Registers

– Map Tristate Cells to Muxes
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– Physical Synthesis

– SNAP

– Optimize Instantiated Gates

– Disable Sequential Optimization 

4. Click on the Constraints tab.

Figure 12:  Set Constraints 

For this exercise, the target default frequency is set to 10 MHz. Also, the 
fifo.sdc constraint file is enabled to use for synthesis. The capaci-
tance/resistance scaling factors that allow some flexibility in place-
ment-based wire estimates is set to the following values:

– Wire Capacitance Scale Factor to 1.0.

– Wire Resistance Scale Factor to 1.0.
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5. Click on the Floorplans tab.

Figure 13:  Set Floorplan Options

From this panel select the input floorplan files for your design. For this 
exercise, make sure the following floorplan files are enabled:

– 69552.ai.def

– fifo.flr
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Figure 14:  Set Implementation Results Options

6. Click on the Implementation Results tab.

From this panel, you specify the directory in which the results are 
written. The Amplify ISSP Pro tool automatically outputs:

– Structural Verilog netlist (.vma) that you can use for place and route 
and/or gate-level simulation.

– Constraints file for forward annotation (.scf)
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7. Click on the Verilog tab.

For this exercise, the top-level module specified in the project is 
packet_buffer_with_io_cts_pll, so it is optionally not specified on this panel.

Figure 15:  Set Verilog Options

8. Click OK to save the implementation options for rev_1.

9. Save the project file (File-> Save).
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Verify Timing Constraints
Amplify ISSP Pro synthesizes a design from top-down, so you only need to 
specify chip-level timing constraints before running synthesis. You can 
specify these constraints through the SCOPE (Synthesis Constraints Optimi-
zation Environment) UI which is a spread-sheet that creates timing 
constraints in Tcl command format. Through the SCOPE UI, you can define 
the following types of constraints:

• Clock definition

• I/O delays 

• Input drive strength

• I/O loads on top-level ports

• Multi-cycle paths

• False paths 

• Min/max paths

• Attributes

• Compile points

• Physical attributes

• Define clock delays

These constraints are defined in Chapter 3, Timing Constraints Set-up. See 
Defining Constraints Using the SCOPE GUI of the User Guide for details. 

To specify constraints for the tutorial design:

1. Compile the design using Run->Compile Only or F7 so that the pertinent 
design information (such as net names, clocks, and so on) is available 
when you create timing constraints in SCOPE.

The job completes with some warnings, which can be ignored for now.

2. Open a constraints file. To do this, click on the SCOPE button ( ). An 
initialization dialog box displays. 
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3. Leave all constraint types enabled and click OK. 

This initializes the SCOPE file with pertinent design-object information. 
This way, you can select design object names from pull-down menus in 
certain fields of the SCOPE panels making it easier to define the 
constraints.

4. For this exercise, specify the clock definition, delays, multi-cycle paths, 
false paths, and attributes as shown in the following figures:

Figure 16:  Clocks

Figure 16 shows the clock definition for the fifo design. The design 
contains the following:

The READ and WRITE clocks from the pads:

– READ_CLOCK_IN
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– WRITE_CLOCK_IN

The READ and WRITE clocks from the PLL:

– pll_rd.CLKOA

– pll_wr.CLKOA

Figure 17:  I/O Delays

Figure 17 shows the I/O delays to set for the design. 

Figure 18:  Multi-Cycle Paths

Figure 18 shows the multi-cycle path allowed to the ports 
DATA_OUT[31:0]. This constraint specifies 2 additional clock cycles to 
these paths for timing analysis and optimization.

Figure 19:  False Paths
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A false path is set for the paths originating from port SYS_RESET. See 
Figure 19. All of these paths are ignored during optimization. You might 
want to disable this false path constraint to find out if other critical 
paths exist from input ports.

5. Click on the Attributes tab and specify the syn_ideal_net on the nets as 
shown in the following figure. First, select the attribute from the 
pull-down.

Figure 20:  Attribute Specification

The software treats any net with the syn_ideal_net attribute as if it has 
infinite drive, therefore it is not buffered during optimization. (See the 
description column Figure 20). Normally, a buffer tree is inserted during 
place and route for a reset net, so it does not need to be optimized.
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Figure 21:  Other

Defines edge-to-edge delay for clocks in the design. The delay values 
specified in Figure 21 for this constraint override calculations made by 
the software. 

6. Save the SCOPE file in the constraint directory as fifo.sdc. 

7. Click Yes when you are prompted to add the constraint file to the project.

8. Close or minimize the SCOPE UI.

9. Save the project file.

For complete descriptions of the constraints and details on applying them, 
see Chapter 3, Defining Constraints Using the SCOPE GUI of the User Guide. 
See Appendix A, Attributes and Directives in the Reference Manual for infor-
mation on attributes. 
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Run Constraint Check
Use the Run->Constraint Check command to generate a report that checks the 
syntax and applicability of the timing constraints in the .sdc file(s) and/or 
.scn (test constraints) file in your project. The report is written to the 
project_name.cck file and contains information on the following items:

• Constraints that are not applied 

• Constraints that are valid and applicable to the design

• Wildcard expansion on the constraints

• Constraints on objects that do not exist

Check the Constraint Check Report
When the constraint check command completes, the constraint check report 
is automatically opened. To open the file when it is closed:

• Double-click on the packet_buffer_with_io_cts_pll.cck file in the 
Implementation Results directory. 

• Click on the Constraint Checker Report in the HTML log file.

The following figures display a sample of the report. The report starts with 
design information and a summary of the applicable and inapplicable 
constraints.
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The following sections include details for each constraint check from the 
summary list provided above.

.

.

.

.

.

.
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The final section contains a library report for the cell libraries.

.

.

.
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View the Floorplan
The Floorplan Editor is a graphical analysis tool to display the floorplan. 
Since a good floorplan is an important phase of physical synthesis, use the 
Floorplan Editor to determine the current state and quality of the floorplan. 
The Floorplan Editor can be displayed anytime after the design has been 
compiled. 

You can display device floorplan information, such as, die size, pin locations, 
macro locations and orientation, rows, or obstructions. The Floorplan Editor 
also provides additional features for graphically editing the floorplan. To bring 
up the Floorplan Editor, click on the Floorplan Editor icon ( ). The following 
figure displays the floorplan for the tutorial design.
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Synthesize the Design
To synthesize the design, click on the Run button in the Project view (or select 
Run->Synthesize). The Amplify ISSP Pro tool goes through the Compiling and 
Mapping phases. When the job is complete, Done! displays in the Project view. 
However, in this case there are some warnings to check.

The following figure shows the UI after synthesis is complete. A list of the 
output results files is shown in the right pane of the Project view. 
Double-click on the files to display them.

Analyze Results
After a synthesis run you need to determine if your design has met the goals 
for area and performance before going on to place and route and/or verifica-
tion. You can verify results through the reports generated during optimization 
and visually through the features of the HDL Analyst schematic views or the 
Physical Analyst floorplan view.
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When analyzing reports, here are the most important areas to cover:

• Warnings–determine which should be addressed and those that are for 
information only and can be ignored 

• Timing results–determine if the target frequency for the design has been 
met.

• Area report–determine if the cell usage is acceptable for your design.

You can visually inspect areas of the design through the hierarchical 
RTL-level and technology-primitive level schematics generated by the HDL 
Analyst and Physical Analyst features. You can also view and isolate the 
critical paths, search for and highlight design objects and crossprobe between 
the schematics and source files. This section describes the various reports 
generated and presents a brief overview of the HDL Analyst and Physical 
Analyst views.

Results Files
After you compile or synthesize your design, the output files are created and 
are displayed in the right pane of the Project view. Double-click on the files to 
display them. See Output Files on page 2-7 for information on these files.

The log file is written (or overwritten) each time you compile or synthesize the 
project in two file formats: text (project_name.srr) and HTML with an interac-
tive table of contents (project_name.htm). To view the log file in HTML, be sure 
to enable the View Log File in HTML option on the Options->Project View Options 
dialog box. This is the default.

Reports
After synthesis, results on timing and area are available in the log file located 
in the directory that you specified through the implementation options dialog 
box earlier in the process (in this case, rev_1). The contents of the log file for 
this exercise are in the text packet_buffer_with_io_cts_pll.srr or the HTML 
packet_buffer_with_io_cts_pll.htm file.

To display the log file, you can do any of the following:

• Double-click on the file in the Project view

• Click on the View Log button in the Project view
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• Select View->Log File 

The output is divided into sections that contain the following information:

• Compiler Report—lists the compiled modules for synthesis

• Mapper Report—contains a running history of the processes required to 
map your design

• DRC Report—lists the types and number of DRC errors

The reports mentioned above can output:

– Syntax or synthesis warnings, errors, and notes

– A running history of the process steps required during each phase of 
synthesis, respectively

– State machine extraction information, including a list of reachable 
states if the symbolic FSM compiler is turned on during synthesis

• Timing Reports

Additionally, the HTML log file separates output for the contents of the 
following sections:

• Session Log—displays a running history of the set-up, operating condi-
tions, and processes used by the tool during synthesis

• Run Option—lists the user options set for synthesis

• Optional Reports—For example, Constraint Checker Report is displayed if 
you run the Constraint Check command.

Click on the sections listed in the table of contents of the HTML log file to take 
you to the top of the section you selected and display its contents on the 
right-side of the viewer.

The file contains these sections on timing information:

• Overall timing information on the design

• Performance summary for the design

• Clock relationships

• Information on top-level ports

• Five starting and ending points with worst slack

• Critical path 
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Delay numbers are computed based on the wire-load model, operating condi-
tions and the constraints that you specify.

These are the most important areas to analyze in the report:

• Warnings–determine those that need resolution and those that are for 
information and can be ignored.

• Timing results–determine if the timing constraints for the design have 
been met.

• Area report–determine if the area is acceptable for your design.

The remaining sections provide examples of these reports.

Warnings
Warnings are displayed in the log file (packet_buffer_with_io_cts_pll.srr or 
packet_buffer_with_io_cts_pll.htm). Scroll through the file to check the 
warnings issued to determine which warnings, if any, require action. 
Figure 22 shows the results for packet_buffer. Your results might vary.

Figure 22:  Log File Warnings
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You can also check for synthesis messages in the Tcl window of the Project 
view by clicking on the Messages tab of the message viewer. Use the live links 
to bring up the online help for the message ID if it is documented or go the 
location in the HDL source file or log file associated with this message.

The log file contains the following types of warnings:

@W| RtMaxNetLength. Skip large-fanout(139)net(name=reset_tree_i_0) 
for routing.

@W:"C:\software\amplify_issp\tutorial\ISSP_DEMO_lib\naming_rule\
naming_rule_MACRO.nr":12:26:12:26|found more than one max_length 
rule. The tightest will be used.

@W: AI335 |Pin YB of TB7NAND2XB lies outside cell bounding box

@W: AI355 |Array statement missing in the floorplan file. Master 
name from physical library(69552) will be used

@W: AI355 |Embedded CTS switch is turned off. ECTS will not be 
performed

@W: AI355:"C:\software\amplify_issp\tutorial\ISSP_DEMO_lib\lef\
7L_io40u.ai.lef":555546:0:555546:0|Parser warning message: SITE is 
defined before ORIGIN.. Last read token was <;>

@W: AM240 |Versions of Library ISSP90_CONFIG and the ASIC mapper 
differ. The library version: 3.3.0N, Build 013R and Mapper version: 
5.0, Build 168R

@W: BN248 |Using default thresholds for library 'ISSP90_CONFIG'

@W: BN216 |Library scaling: nominal PVT are not complete for 
library ISSP90_CONFIG - scaling ignored for this library; data left 
as-is
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@W: MF215 :|Ignoring syn_ideal_net work on the clock 
write_clock_tree_keep

@W: CG370 :"C:\software\amplify_issp\tutorial\rtl_sims\
async_fifo.v":47:19:47:23|No assignment to wire ecomp

Unused wire inputs/outputs are ignored. You should assign connections to 
these wires if you want to keep these unused wires in the design. You can 
ignore the warning about the different versions of the library files and the 
mapper. The technology library file (.syn) was generated from a different 
version of the mapper software.

You would also need to fix design rule violations or any other warnings in the 
design that are not acceptable. However, for the tutorial exercise, you can 
ignore these warnings.

Timing Report
With each synthesis run, default timing information is reported that consists 
of the following sections, first for maximum delay, then for minimum delay:

• Performance summary, including the worst max/min slack for the 
design as well as the worst max/min slack for each clock in the design.

• Arrival and required time as well as slack for all the top-level ports of the 
design (interface information section)

• Five worst starting points in the design (ordered by slack) (a starting 
point is either a primary input or a register output or the output of a 
black-box).

• Five worst ending points in the design (ordered by slack) (an ending 
point is either a primary output or a register input or the input of a 
black-box).

• Critical path in the design, including the starting and ending points as 
well as each point in between.

Delay numbers are computed based on the wire-load model and operating 
conditions specified through the Implementation Options dialog box, and the 
constraints specified in the .sdc file.
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Figure 23 shows the beginning of the Max Analysis timing report for the fifo 
design.

Figure 23:  Timing Report

Check the Performance Summary section for the worst slack for this design. 
Depending on the version of the software that you are using and the platform 
you are running on, your results may vary.

Check all sections of the Max Analysis timing report, then the Min Analysis 
timing report to ensure the design has met the timing requirements. Scroll 
through and use Edit->Find to search the report. 

You might need more detailed information than what is provided in the 
default report, such as information on a specific path or you might want to 
see more than just the worst path. For these requirements, you can 
customize a report using Analysis->Timing Options. 
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Figure 24:  Timing Report Generation

The Timing Report Generation dialog box is shown in Figure 24. You can also 
generate this report using back annotated SDF data. 

1. Select Analysis->Timing Options.

2. Change the Limit Number of Paths to 5.

3. Make sure the name of the report is packet_buffer.ta, then click 
Generate.

This step generates and displays the report. You can see the file 
packet_buffer.ta in the right pane of the Project view. 

4. Double-click on this file and scroll through the results.

For complete details on reports, see Generating Timing Reports and Analyzing 
Timing Reports in Chapter 6, Analyzing Synthesis Reports of the User Guide.
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Area Report
In the packet_buffer_with_io_cts_pll.srr (log file), scroll down to the Report 
for cell ... section which begins just after the timing report section. In the 
packet_buffer_with_io_cts_pll.htm file, click on Cell Usage in the HTML 
table of contents. Figure 25 shows a sample. Library cells are listed in order 
of quantity of use. The total area for the design is given at the end of the 
section. 

Figure 25:  Cell Usage Report

Total Area for the Design
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The cell usage section shows the following columns:

• cell–name of the library cell

• count–number of cells used in the design

• area–size of one cell in the units defined in the technology library

• count * area–total area used in the design all instances of the library cell

Figure 25 shows that total area for this design is 373969.0. Depending on the 
version of the software that you are using and the platform you are running 
on, your results may vary slightly. The area units in the report are determined 
by the units specified in the cell library. 

Physical Synthesis Reports
In addition to the standard timing and area reports displayed in the log file 
(.srr/.htm), the physical synthesis reports include:

• Floorplan Summary

• Pin Pair and Fanout Reports

• Congestion Report

• Design Summary

Floorplan Summary
This information is provided as the floorplan file is loaded, before the Mapping 
Phase of synthesis begins. Search for the Floorplan Summary string to view the 
summary.



LO

Analyze Results

50 Amplify ISSP Pro Tutorial, September 2005

Pin Pair and Fanout Reports
This report provides information on the pin pairs (includes ideal and clock 
nets) and fanouts (excludes ideal and clock nets) in the design. Search for the 
Pin Pair Report or the Fanout Report string.

Congestion Report
This report identifies hot spots for congestion and the percentage of track 
utilization on the device. Congestion usage is computed by comparing the 
routing demands through the bins to the available routing resources in both 
the horizontal (x) and vertical (y) directions on the device. Search for the 
Congestion Report string. The congestion report should be used in conjunction 
with the congestion map displayed in the Physical Analyst.

See the Amplify ASIC Physical Optimizer Design Flow and the Physical Analyst 
chapters of the Synplicity ASIC User Guide for more information.

Design Summary
In addition to the floorplan summary presented earlier in the log file, this 
summary includes row and area utilization. These numbers show how much 
of the placeable areas are utilized by the design. Row utilization consists of 
cell information only. Area utilization includes cells and macros. Search for 
the Design Summary string.
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HDL Analyst Views
HDL Analyst is a graphical productivity tool that helps you visualize the 
synthesis results. HDL Analyst generates hierarchical RTL-level and 
technology-primitive level schematics from VHDL and Verilog designs, and 
lets you crossprobe between the RTL-level and technology-level views and 
your HDL source code. HDL Analyst also highlights and isolates critical paths 
within your design so you can analyze problem areas, add timing constraints 
and resynthesize.

1. Generate the RTL view for your design with the corresponding button in 
the UI ( ) or through HDL Analyst->RTL->Hierarchical View.

2. Generate the Technology view using the corresponding button ( ) or 
through HDL Analyst->Technology->Hierarchical View.

Figure 26 and Figure 27 show the RTL and Technology views for the fifo 
design.
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Figure 26:  RTL View 

Figure 27:  Technology View (Zoomed in to a Portion of the View)
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View Critical Path
View the critical path for the design in the Technology view. To do this:

1. Flatten the Technology view schematic using HDL Analyst->Flatten current 
schematic (or HDL Analyst->Technology ->Flattened View). 

2. Click on the Show Critical Path button in the UI ( ) or select HDL 
Analyst->Show Critical Path from the menus. 

Figure 28:  Show Critical Path

Figure 28 shows the critical path for the afifo.empty. You can also show 
this view selecting HDL Analyst -> Technology -> Flattened Critical Path.

3. Zoom into the blocks on the right side of the view. 
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Figure 29:  Slack and Cumulative Delay

Timing numbers are annotated on the top-left corner of the instances, 
showing the cumulative delay to the instance and slack time of the path 
that goes through the instance. As shown in Figure 29, slack is 4.96 ns 
and delay is 0.99 ns to instance: fept.

Depending on the version of the software that you are using and the 
platform you are running on, your results may vary slightly.

Physical Analyst View
The physical analyst provides a visual and analytical display of the floorplan, 
placement, and global routing of the design after physical synthesis. The 
Physical Analyst view shows the device, device ports, instances, nets, 
obstructions, and congestion and row utilization maps. The view displayed is 
flat, although the hierarchy of the instance name is retained.

To bring up the Physical Analyst viewer, click on the Physical Analyst icon 
( ) from the Physical Analyst toolbar.

View Critical Path
The Physical Analyst tool makes it simple to find and examine critical paths 
and the relevant source code. The following procedure shows you how to filter 
and analyze a critical path. 
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1. Display the critical path using one of the following methods. The 
Physical Analyst view highlights the instances and nets in the most 
critical path of your design. To generate a view of the critical path:

– Click on the Show Critical Path icon (stopwatch icon ).

– Right-click and select Critical Path->Show Critical Path from the popup 
menu. 

2. To view only the critical timing path, first filter all objects. To do this:

– Click on the Filter on Selected Gates icon ( ).

– Right-click and select Filter->Show Selected from the popup menu.

3. You can also filter site locations from the device so that you have a better 
view of the critical path in the Physical Analyst view. To do this:

– Click on the Physical Analyst Control Panel icon ( ) to display the Control 
Panel.

– On the Objects tab of the Control Panel toggle visibility of sites off.
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4. To find the critical path end point:

– Right-click and select Find from the popup menu.

– On the Object Query dialog box of the Instances tab, select the Critical path 
end command from the Filter Search option. See Object Query on 
page 2-59.

– Use the Find All button to locate all instances of this search. For this 
example, move the selected instance dout0 from the Unhighlighted to the 
Highlighted pane.

– Close the dialog box. The critical path end point is highlighted in the 
Physical Analyst view.

– Zoom in on this object.

– Move the cursor over the critical path end point instance. A tool tip 
displays the cumulative delay to the instance and slack time of the 
path that goes through the instance.



Analyze Results Amplify ISSP Pro Tutorial for ISSP-90

Amplify ISSP Pro Tutorial, September 2005 57

Display the Congestion Map
The routing congestion map visually displays routing congestion. The 
routable area is divided into bins. As nets are routed, their routing demands 
(design and bins) are compared to the routing resources (technology, layers, 
pitch, and obstructions) for each bin.

A graduated color bar displays a progression of up to 20 colors from the 
threshold percentage value up to the alert percentage value. Congestion hot 
spots are displayed using the burn or alert colors. Congestion utilization is 
based on the maximum percentage value in either the horizontal (X) or 
vertical (Y) direction for each bin. A tool tip displays these X and Y percentage 
utilizations. The higher the percentage, the higher the routing density. 

To display the congestion map in the Physical Analyst view:

1. Click on the Physical Analyst Control Panel icon ( ) to display the Control 
Panel.

Pad cell fept 
Type = TUD7OC33N09NU
Location = (-2020.00,4631.00)
Orientation = S (180)
Placement = Fixed
Delay = 4.9570
Slack = 0.9930
Path Status = End of critical path
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2. On the Maps tab of the Control Panel, select Routing Congestion from the 
drop-down menu for the Maps Routing option. Then click Draw.

3. In the Physical Analyst view, use tool tips to display the X and Y 
percentage utilizations on the device with the threshold set to 50%.

Display the Row Utilization Map
The row utilization map provides visual and analytical display of the 
percentage of site utilization for each bin in the placeable area. The row utili-
zation data is available after the design is placed.

A graduated color bar displays a progression of up to 20 colors that ranges 
from the threshold value up to the alert value. Bins with high site utilization 
are displayed using the burn or alert colors. Bins below the threshold level 
are displayed in the cool (blue) color; tool tips are available for displaying the 
percentage of utilization.

To display the row utilization map in the Physical Analyst view:
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1. Select Row Utilization from the drop-down menu on the Maps tab of the 
Control Panel. Then click the Draw button. 

2. When Utilization is enabled, the row utilization map is displayed and tool 
tips reporting the percentage of utilization for each bin are available. 

Object Query
You can highlight various design objects in the schematics and cross probe 
between the views, the source code and the log files. To bring up the Object 
Query dialog box, in the RTL, Technology, or Physical Analyst view, right-click 
and select Find in the popup menu. Go through the tabs and highlight 
different objects in the schematics or floorplan.
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Figure 30:  Object Query–Instances

Figure 31:  Object Query–Nets
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For More Information
For more information on all the features covered in the tutorial design flow, 
see Chapter 3, Timing Constraints Set-up, Chapter 6, Analyzing Synthesis 
Reports, and Chapter 2, Project Set-up in the User Guide. Chapter 7 and 
Chapter 8 also provide complete details on using HDL Analyst and Physical 
Analyst for the following:

• Flattening Hierarchy

• Filtering Schematics

• Extending Selected Logic

• Viewing Critical Paths in HDL Analyst

• Viewing Critical Paths in Physical Analyst

• Handling Negative Slack
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